Author Topic: Any rear brake issues after AST peg lowering?  (Read 300 times)

0 Members and 1 Guest are viewing this topic.

Offline parttimer`

  • Tricycle
  • Posts: 29
  • AREA: North Central Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Any rear brake issues after AST peg lowering?
« on: June 13, 2018, 04:02:15 pm »
I have noticed since I first installed my lowering kit on my 17, the rear brake pedal needs "pumped" before the brakes will engage now.  If I just press the pedal pretty much nothing happens, if I lift and press again it grabs right away.  If I ride for a few minutes, I have to repeat the process.  Any ideas?  I didn't disconnect any brake lines, just moved the pedal down with the kit. 

Offline FTB530

  • Street Cruiser
  • ****
  • Posts: 711
  • AREA: Southwest Area
  • COG#: 12127
  • Membership Level: Active
Re: Any rear brake issues after AST peg lowering?
« Reply #1 on: June 13, 2018, 07:32:17 pm »
I had those on two bikes never had that problem! Do you still have stock pipe?

Offline parttimer`

  • Tricycle
  • Posts: 29
  • AREA: North Central Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Any rear brake issues after AST peg lowering?
« Reply #2 on: June 15, 2018, 11:56:30 am »
Stock pipe, I cut the head shield as well.  Push the pedal and it sinks all the way, easy up a tiny bit, push back and it works.  Every time.  Weirdest thing.

Offline FTB530

  • Street Cruiser
  • ****
  • Posts: 711
  • AREA: Southwest Area
  • COG#: 12127
  • Membership Level: Active
Re: Any rear brake issues after AST peg lowering?
« Reply #3 on: June 15, 2018, 01:14:13 pm »
Did you adjust the brake linkage any?

Offline parttimer`

  • Tricycle
  • Posts: 29
  • AREA: North Central Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Any rear brake issues after AST peg lowering?
« Reply #4 on: June 15, 2018, 06:56:36 pm »
I made no adjustments, in the video he shows having to shave that back piece off, but on my 17 the pedal moves fine, looks like they made changes to it for the model year. I am tempted to put the peg back to stock and see if it happens still.

Offline TJ

  • Tricycle
  • Posts: 27
  • AREA: North Central Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Any rear brake issues after AST peg lowering?
« Reply #5 on: June 16, 2018, 10:08:08 am »
I have noticed since I first installed my lowering kit on my 17, the rear brake pedal needs "pumped" before the brakes will engage now.  If I just press the pedal pretty much nothing happens, if I lift and press again it grabs right away.  If I ride for a few minutes, I have to repeat the process.  Any ideas?  I didn't disconnect any brake lines, just moved the pedal down with the kit.

Had the same problem on my '17 after installing the brackets. Dealer looked at it while it was in for 600 miles service and cruise control install. Found the pedal was either making contact with the bracket, or an issue related to that. Anyway, they fixed it quite easily.

Offline FTB530

  • Street Cruiser
  • ****
  • Posts: 711
  • AREA: Southwest Area
  • COG#: 12127
  • Membership Level: Active
Re: Any rear brake issues after AST peg lowering?
« Reply #6 on: June 16, 2018, 10:52:26 am »
On my first 16 I mounted the brackets ,the instructions had something about grinding a spot ,was not necessary. But there was a pin that went through the linkage that I pulled out and turned around the opposite of what it was , because it had about a hairs width of clearance. Had no problems with it!

Offline ghostrider990

  • Street Cruiser
  • ****
  • Posts: 778
  • AREA: Southeast Area
  • COG#: 12649
  • Membership Level: Active
Re: Any rear brake issues after AST peg lowering?
« Reply #7 on: June 20, 2018, 12:19:34 pm »
That rear brake is a useless P.O.S. on it's BEST day.  ::)

The linked setup on my '12 is so abrupt, finicky, and unpredictable, that I have stopped using it for anything but sheer panic episodes.

Really my lone GLARING gripe about the whole bike.  Others are simply minor by comparison -- the rear brake is borderline dangerous, imho.

gr
..."I like to keep this handy -- for Close Encounters"...

Offline Gumby40

  • I'm Gumby dammit! (Eddie Murphy, SNL)
  • Tricycle
  • Posts: 29
  • '98 Conrad
  • AREA: North Central Area
  • COG#: 11474
  • Membership Level: Active
Re: Any rear brake issues after AST peg lowering?
« Reply #8 on: June 20, 2018, 10:55:47 pm »
Stock pegs on mine and the rear brake works better after a pump.
'74 CR125,'78 CR250,'79 YZ400, '78 Yamaha 650 Special, '80 Yamaha Maxim, '80 Honda CM400a,'85 Ninja 600,'86 CR250,'98 Suzuki Bandit 1200,'98 C-10, 2013 C14