Author Topic: Forum Move and Upgrade  (Read 7377 times)

0 Members and 1 Guest are viewing this topic.

Offline Colin

  • Crotch Rocket
  • ****
  • Posts: 1883
  • I'd rather be riding!
    • Facebook
  • AREA: Northwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Forum Move and Upgrade
« on: September 25, 2011, 03:05:37 pm »
I am going to post this here which I appreciate is incorrect, but wanted to make sure everyone sees it!


I am planning to move this forum to a new Server either tonight (Sunday Night) or on Monday.


The new server is hosted at a new service provider which I expect to provide a better quality of service and performance. However that's NOT Guaranteed!  ??? 
Due to this my plan is as follows (this is important!)


  • I will backup this server and put it in maintenance mode so you will not be able to use it.
  • I will restore the backup onto the new server, and make sure all looks to be running ok
  • Once all is well I will put a link on the current forum/server to the new one.
    If all goes well the Forum will only be down for a couple of hours. Perhaps less.
  • The upgraded forum will run on the new server for a week or so on a Temporary domain while we make sure the new service provider is solid and they deliver the performance we need.
  • If all is well I'll switch the domains over, if not I'll upgrade the current server and switch back.
The new server is already loaded with the latest version of SMF software and we have installed a Media Gallery and a Wiki Style Section.
Both these 2 areas will take more moderation and management, please be patient with us while we "figure it all out"


Media Gallery
This will allow members to post images, video's and Audio files for storage and display.


COG Wiki
This will potentially replace our current Tech Section on Cog-Online.org and allow select users to create and edit the content, and I hope any user post a discussion on.


Video
Ability to easily embed video from YouTube etc into a post.
<Update> Looks like we have to turn this off, there seems to be a security risk.


I'm looking forward to rolling this all out to y'all!


Colin.
PS I'm sorry to say that the spell checking feature is not working on the new server. However I hope to get that fixed at some point. I am working on it!   


 
« Last Edit: September 26, 2011, 03:03:10 pm by Colin »
Colin Prior

Offline Colin

  • Crotch Rocket
  • ****
  • Posts: 1883
  • I'd rather be riding!
    • Facebook
  • AREA: Northwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Forum Move and Upgrade
« Reply #1 on: September 26, 2011, 04:38:02 am »
So far as I can tell all is well. :-X
<edit>spoke to soon, I had to go back and re-do the database upgrade.


The new Media library is up and running, but please don't use it till we figure out the rules and assign a moderator.
The embedding of video from external sites does work see the following post.


I have not re-installed the Wiki yet. WillP or I will do that tomorrow.


I will also change the links on the cog-online.org  and concours.org websites tomorrow. <Done>


If all looks good by next Friday I'll swap the domain over on Sunday/Monday.


I'm off to bed!

Go ahead and play, please report here any issues you have.


Many Thanks!


Colin
« Last Edit: September 26, 2011, 03:03:48 pm by Colin »
Colin Prior

Offline Cap'n Bob

  • GOLD STAR
  • *******
  • Posts: 10952
  • AREA: Northeast Area
  • COG#: 7134
  • Membership Level: Active
Re: Forum Move and Upgrade
« Reply #2 on: September 26, 2011, 07:31:43 am »
I guess we moved.  :)

Offline Camper Dave

  • Crotch Rocket
  • ****
  • Posts: 1671
    • The WOG
  • AREA: Southeast Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Forum Move and Upgrade
« Reply #3 on: September 26, 2011, 09:21:00 am »
Ya but you got to log back in...I'm sure that will make a few grumpy  :-[
<--- is there any mechanism in place to deal with a non- productive, antagonistic, former non- member such as this?

Offline Clinton

  • Mini Bike
  • **
  • Posts: 162
  • Woo Hoo!!
  • AREA: Southeast Area
  • COG#: 9399
  • Membership Level: Active
Re: Forum Move and Upgrade
« Reply #4 on: September 26, 2011, 10:20:16 am »
I believe, if i understand the info correctly, the domain name, zg1000, is only temporary until we confrm the new host, the "person" letting us use their high speed gadgetry, is up to par.  At that time, the domain name will return to cog-online.o r g.     
 
But....if i also understand correctly, we really cant chat about anything becuase when we switch back, anything new will be deleted?

2008 Kawasaki Concours 14

Offline Fred_Harmon_TX

  • COG Technical Editor
  • Industry Member
  • Iron Butt
  • *
  • Posts: 3155
    • Angel Ride Videos
  • AREA: South Central Area
  • COG#: 2170
  • Membership Level: Active
Re: Forum Move and Upgrade
« Reply #5 on: September 26, 2011, 10:47:54 am »
Thanks Colin, seems to be running good.
Fred H.


Thanksgiving Sale in Effect now!  Concours 1400 Maintenance Videos 
http://www.angelridevideos.com

Offline KawiMick

  • Mini Bike
  • **
  • Posts: 141
  • AREA: Southwest Area
  • COG#: 8969
  • Membership Level: Expired - Expired Term
Re: Forum Move and Upgrade
« Reply #6 on: September 26, 2011, 11:42:53 am »
It sure is faster, seems to be at least twice as speedy as the old one. 
Hope it lasts........

Mick
Mick
Tucson/Santa Paula
     
'84 R100RS(sold) (unsold)
'93 K1100LT 
'96 R1100RT
'10 C14 VIN 000643 
  COG#8969
Born OK the First Time

Offline S Smith

  • Northeast Area Director
  • Officer
  • I Need a Life
  • ****
  • Posts: 5254
    • COG Northeast Area Home Page
  • AREA: Northeast Area
  • COG#: 3184
  • Membership Level: Administrator
Re: Forum Move and Upgrade
« Reply #7 on: September 26, 2011, 12:24:24 pm »
I believe, if i understand the info correctly, the domain name, zg1000, is only temporary until we confrm the new host, the "person" letting us use their high speed gadgetry, is up to par.  At that time, the domain name will return to cog-online.o r g.     
 
But....if i also understand correctly, we really cant chat about anything becuase when we switch back, anything new will be deleted?


No, that was just a test of this server, now we are here to stay. But if you had bookmarked any threads, you will have to change the bookmark to reflect the new domain.

For example, http://forum.cog-online.org/index.php/topic,27119.msg108776/topicseen.html#msg108776
Becomes: http://forum.zg1000.org/index.php/topic,27119.msg108776/topicseen.html#msg108776


I would wait changing any bookmarks, as the forum domain will change again once the new hosting is stabilized.

| Steve Smith | COG #3184 | MSF/CONREP RC |

There is more to be gained by members raising hands saying "I'll do that" instead of pointing fingers saying "nobody's doing that."

Offline Colin

  • Crotch Rocket
  • ****
  • Posts: 1883
  • I'd rather be riding!
    • Facebook
  • AREA: Northwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Forum Move and Upgrade
« Reply #8 on: September 26, 2011, 12:55:59 pm »
I believe, if i understand the info correctly, the domain name, zg1000, is only temporary until we confrm the new host, the "person" letting us use their high speed gadgetry, is up to par.  At that time, the domain name will return to cog-online.o r g.     
 
But....if i also understand correctly, we really cant chat about anything becuase when we switch back, anything new will be deleted?


Correct on the domain switching back to forum.cog-online.


Incorrect that if we do we will loose posts!
In the UNLIKELY event we need to switch back, I would upgrade the old server to 2.0 add the new features that you find here and then restore all the latest posts etc.  :beerchug:
Colin Prior

Offline kawcon14rider

  • Street Cruiser
  • ****
  • Posts: 787
  • AREA: Southeast Area
  • COG#: 8557
  • Membership Level: Active
Re: Forum Move and Upgrade
« Reply #9 on: September 26, 2011, 02:05:54 pm »
Looks like we have some uninvited guests in the forum rules section. Hello Kitty and heterogeneous?
« Last Edit: September 26, 2011, 02:11:18 pm by kawcon14rider »
Sammie Timmons  COG# 8557  CDA#0291  AMA# 818592 SCAAD 74 GT380 totaled  74 GT750 totaled  80 GS850 totaled  05 Vulcan 750 traded  08 C14 my baby  08 Versys (my wife's) 2012 Ninja 250 [thanks Kawasaki for the gift]

Offline Colin

  • Crotch Rocket
  • ****
  • Posts: 1883
  • I'd rather be riding!
    • Facebook
  • AREA: Northwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Forum Move and Upgrade
« Reply #10 on: September 26, 2011, 02:47:11 pm »
Looks like we have some uninvited guests in the forum rules section. Hello Kitty and heterogeneous?


Yes I had not re-installed the integration plugin with memberize correctly so it was allowing the "general public" ie those that don't have Connies to register LoL   :))


This is now fixed. I removed the offending 5 new "spam" members that got in. Sorry about that!
 
Colin Prior

Offline Colin

  • Crotch Rocket
  • ****
  • Posts: 1883
  • I'd rather be riding!
    • Facebook
  • AREA: Northwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Forum Move and Upgrade
« Reply #11 on: September 26, 2011, 03:07:58 pm »
Ok I am off to do my day job now.


There is an intermittent issue with the cache.
You may get an error message like this:


Fatal error: require() [function.require]: Failed opening required
'/nfs/c09/h03/mnt/133072/domains/forum.zg1000.org/html/cache/data_7d07cd92e1f4bce8d5a37262895a8e9e-
SMF-modSettings.php' (include_path='.:/usr/local/php-5.2.17/share/pear') in /nfs/c09/h03/mnt/133072/domains/forum.zg1000.org/html/Sources/Load.php on line 2712



simply refresh  with F5 or however you like to refresh/reload the page and all should be fine.
I'm trying to figure out what this is about.


The good news is the server is way faster than the old one.


Colin
« Last Edit: September 26, 2011, 03:10:17 pm by Colin »
Colin Prior

Offline Clinton

  • Mini Bike
  • **
  • Posts: 162
  • Woo Hoo!!
  • AREA: Southeast Area
  • COG#: 9399
  • Membership Level: Active
Re: Forum Move and Upgrade
« Reply #12 on: September 26, 2011, 07:49:35 pm »
I believe, if i understand the info correctly, the domain name, zg1000, is only temporary until we confrm the new host, the "person" letting us use their high speed gadgetry, is up to par.  At that time, the domain name will return to cog-online.o r g.     
 
But....if i also understand correctly, we really cant chat about anything becuase when we switch back, anything new will be deleted?


Correct on the domain switching back to forum.cog-online.


Incorrect that if we do we will loose posts!
In the UNLIKELY event we need to switch back, I would upgrade the old server to 2.0 add the new features that you find here and then restore all the latest posts etc.  :beerchug:

Cheers indeed Colin!  Thanks for all the hard work!!
2008 Kawasaki Concours 14

Offline Camper Dave

  • Crotch Rocket
  • ****
  • Posts: 1671
    • The WOG
  • AREA: Southeast Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Forum Move and Upgrade
« Reply #13 on: September 26, 2011, 10:56:35 pm »
Yep, I got that error message... I was gonna email it to you but figured I'd check for some kinda notice...  ^-^
<--- is there any mechanism in place to deal with a non- productive, antagonistic, former non- member such as this?

Offline norm-9688

  • Crotch Rocket
  • ****
  • Posts: 1536
  • AREA: Northeast Area
  • COG#: 7011
  • Membership Level: Active
Re: Forum Move and Upgrade
« Reply #14 on: September 27, 2011, 02:14:25 am »
Looks good Colin, thanks for all the hard work !!

Offline Rev Ryder

  • Officer
  • I Need a Life
  • ****
  • Posts: 8800
  • We came. We saw. We Concours-ed.
    • Presbychuck
  • AREA: South Central Area
  • COG#: 7235
  • Membership Level: Executive Director
Re: Forum Move and Upgrade
« Reply #15 on: September 27, 2011, 07:37:17 pm »
Since the site name is now zg1000 are you kicking us C14 guys out?
Parasites.



ER... I mean PAIR O SITES... didja see Colin is now taking care of a pair of sites with out OUR forum on em.  That boy is nuts.

Good job Colin.  Reckon we'll let those C-14 guys hang with us a little longer, eh?   :nananana:
After all, they ARE the more prevalent posters these days... kinda makes me feel old for some reason.
EDIT TO CORRECT SPELLING.... HMMmmmmmm!
Fortis non Ferox
 Shafties Can't Wheelie

Offline Colin

  • Crotch Rocket
  • ****
  • Posts: 1883
  • I'd rather be riding!
    • Facebook
  • AREA: Northwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Forum Move and Upgrade
« Reply #16 on: September 28, 2011, 04:41:16 am »
Thanks all;


And a special thanks to Rev for his infectious humor!   :rotflmao:


Still got a number of minor issues to resolve, but for sure the performance is better!  :)
There is a bit of a delay in getting the wiki up, please be patient.


Cheers


Colin
Colin Prior

Offline Camper Dave

  • Crotch Rocket
  • ****
  • Posts: 1671
    • The WOG
  • AREA: Southeast Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Forum Move and Upgrade
« Reply #17 on: September 28, 2011, 09:33:29 am »
There is a bit of a delay in getting the wiki up, please be patient.
TMI!!! TMI!!!
Oh wiki.... I thought Colin was using one of those cute little brit words for his..umm...never mind  :rotflmao:
<--- is there any mechanism in place to deal with a non- productive, antagonistic, former non- member such as this?

Offline Colin

  • Crotch Rocket
  • ****
  • Posts: 1883
  • I'd rather be riding!
    • Facebook
  • AREA: Northwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Forum Move and Upgrade
« Reply #18 on: September 28, 2011, 01:06:40 pm »

There is an intermittent issue with the cache.
You may get an error message like this:

Fatal error: require() [function.require]: Failed opening required
'/nfs/c09/h03/mnt/133072/domains/forum.zg1000.org/html/cache/data_7d07cd92e1f4bce8d5a37262895a8e9e-
SMF-modSettings.php' (include_path='.:/usr/local/php-5.2.17/share/pear') in /nfs/c09/h03/mnt/133072/domains/forum.zg1000.org/html/Sources/Load.php on line 2712




Has anyone seen this type of error in the last 24 hours?
Basically the whole window is replaced with this message, but if you refresh the page all is fine.
I think its simply a matter of the cache being re-built and the problem has now largely gone away.
However if a number of you are still seeing it I need to know.


I very pleased with the overall performance of the new server and plan to swap over to the forum.cog-online.org domain.


Thanks!


Colin
Colin Prior

Offline Rev Ryder

  • Officer
  • I Need a Life
  • ****
  • Posts: 8800
  • We came. We saw. We Concours-ed.
    • Presbychuck
  • AREA: South Central Area
  • COG#: 7235
  • Membership Level: Executive Director
Re: Forum Move and Upgrade
« Reply #19 on: September 28, 2011, 01:18:17 pm »
Yes, that page has shown itself to me a few times in the past day or so. I have NOT seen it today.
Fortis non Ferox
 Shafties Can't Wheelie

Offline Cap'n Bob

  • GOLD STAR
  • *******
  • Posts: 10952
  • AREA: Northeast Area
  • COG#: 7134
  • Membership Level: Active
Re: Forum Move and Upgrade
« Reply #20 on: September 28, 2011, 05:17:23 pm »
Yes, that page has shown itself to me a few times in the past day or so. I have NOT seen it today.


I got it this morning (early) a few times. But this is the first thread I've read since then, so we'll see. It hasn't been too bad at all.

Offline Mad River Marc

  • Sport Tourer
  • *****
  • Posts: 2278
  • AREA: Northeast Area
  • COG#: 8442
  • Membership Level: Active
Re: Forum Move and Upgrade
« Reply #21 on: September 28, 2011, 05:20:37 pm »
Haven't seen it today or yesterday
You only need two tools in life – WD-40 and duct tape. If it doesn’t move and should, use the WD-40. If it shouldn’t move and does, use the duct tape.

Offline Rev Ryder

  • Officer
  • I Need a Life
  • ****
  • Posts: 8800
  • We came. We saw. We Concours-ed.
    • Presbychuck
  • AREA: South Central Area
  • COG#: 7235
  • Membership Level: Executive Director
Re: Forum Move and Upgrade
« Reply #22 on: September 28, 2011, 05:35:15 pm »
It just hit me again.
Fortis non Ferox
 Shafties Can't Wheelie

Offline smithr1

  • I Need a Life
  • ******
  • Posts: 5251
  • AREA: South Central Area
  • COG#: 6197
  • Membership Level: Asst. Area Director
Re: Forum Move and Upgrade
« Reply #23 on: September 28, 2011, 05:56:16 pm »
I had one of those errors today.  It was about 5 yesterday.

I also feel that twice now when I click on a new to me thread it only showed me the original post and not all the replies.  I have my posts listing from newest to oldest opposite of the default.   When I click on a thread I should see the newest post not the original post at the beginning.  It may have only NOT switched the order and I just failed to notice.  I will keep an eye out.
---
Bob Smith (smithr)
Austin, Texas baby!
2010 Kawasaki Concours, Midnight Blue
COG 6197, CDA 107

Offline GF-in-CA

  • Crotch Rocket
  • ****
  • Posts: 1360
  • AREA: Southwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Forum Move and Upgrade
« Reply #24 on: September 28, 2011, 08:10:31 pm »
I just got it, too.
Gary F.

1998 ZGX1100
Central Valley California