Author Topic: engine doesnt start neutral switch not working  (Read 246 times)

0 Members and 1 Guest are viewing this topic.

Offline osvaldo

  • Big Wheels
  • Posts: 4
  • AREA: Southeast Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
engine doesnt start neutral switch not working
« on: December 30, 2018, 03:28:18 am »
hello and merry Christmas!!!

engine doesn't start neutral switch not working
any idea ?
thanks for your attention !

Offline Freddy

  • Road Bike
  • ***
  • Posts: 319
  • AREA: Southwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: engine doesnt start neutral switch not working
« Reply #1 on: December 30, 2018, 06:11:35 am »
Yeah, I have an old car like that too.  I put a new battery in it and it seemed to fix it.   :)
The best substitute for brains is ..............what?

Offline Bob_C_CT

  • Sport Tourer
  • *****
  • Posts: 2093
  • AREA: Northeast Area
  • COG#: 9544
  • Membership Level: Active
Re: engine doesnt start neutral switch not working
« Reply #2 on: December 30, 2018, 11:11:20 am »
I have a C10 and when the neutral switch went (no neutral light) I could start it with the clutch lever pulled in and then put up the sidestand before letting out the clutch lever, until I had a chance to replace the neutral switch. Hope that helps. Are you sure your in neutral, bike rolls?
97 C10,ZRX Front, Meanstreak rim

Online Steiny

  • Training Wheels
  • *
  • Posts: 89
  • AREA: North Central Area
  • COG#: forum
  • Membership Level: Forum Subscriber
Re: engine doesnt start neutral switch not working
« Reply #3 on: December 30, 2018, 05:30:11 pm »
was your kickstand down ?


Offline Vic

  • Bicycle
  • *
  • Posts: 103
  • AREA: Southwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: engine doesnt start neutral switch not working
« Reply #4 on: December 30, 2018, 11:01:34 pm »
was your kickstand down ?

Or stuck sidestand switch? Happened on my old FZR back in the day...

Offline MAN OF BLUES

  • I Need a Life
  • ******
  • Posts: 8396
  • AREA: North Central Area
  • COG#: 5977
  • Membership Level: Active
Re: engine doesnt start neutral switch not working
« Reply #5 on: December 30, 2018, 11:58:34 pm »
C14 is a bit different, as even with the clutch pulled it, it will kill the engine if the stand is lowered while in gear... just mentioning.

not enough info was given by the o/p, to even start a conversation, year, miles, mods, condition of battery, services prior performed, etc., ... you know, the usual laundry list...
just a question on why his bike don't "werk"...
 :-X :-X :-X :-[ :truce:

30 YEARS OF KAW.....Rich R. (the other one..)  COG 5977  JUSTAMEMBAHNOW
and if you are gonna call me names... it's MR. Analdweeb if you please...