Author Topic: Gauges Go Waco & Bike Dies  (Read 372 times)

0 Members and 1 Guest are viewing this topic.

Offline SandShark

  • Training Wheels
  • *
  • Posts: 54
  • "SandShark"
  • AREA: Southeast Area
  • COG#: 9045
  • Membership Level: Active
Gauges Go Waco & Bike Dies
« on: September 25, 2018, 05:35:10 pm »
2010 C14 and this bike has never giving me a problem.
I have rode it to Calif. twice, Colorado numerous times and Alaska all from Florida without even a hiccup.

Sunday I went of a couple hour ride and after lunch was cruising about 50 when by speed & tac gauges went bat crazy, the red light started flashing & it KTRC started flashing in the window. A few miles down the road when I pulled up to a stop sign it died (DEAD). Could not turn key even using spare card I keep in my wallet. Had the bike towed home.

Next day bike started right up, no problems and road around the neighborhood and it rode perfect. Check battery voltage & connections and they seemed fine. Do you think this was just a fluke or is there something else I need to check.

I did put in a brand new battery two weeks ago.

Thanks,
"It not the destination, but the ride"

COG #9045
2010 C-14 ABS, 2014 WR450F

Offline kv5e

  • Roll miles, Keep smiles
  • Moderator
  • Crotch Rocket
  • **
  • Posts: 1295
  • TARKUS - Texas Bad Boy
  • AREA: South Central Area
  • COG#: 5063
  • Membership Level: Area Director
Re: Gauges Go Waco & Bike Dies
« Reply #1 on: September 25, 2018, 06:12:54 pm »
Double check the ground connection on both the battery and frame.

Sounds like a transient was on the CAN BUSS and the bike went wonky.

Offline MAN OF BLUES

  • I Need a Life
  • ******
  • Posts: 8260
  • AREA: North Central Area
  • COG#: 5977
  • Membership Level: Active
Re: Gauges Go Waco & Bike Dies
« Reply #2 on: September 25, 2018, 09:16:19 pm »
2010 C14 and this bike has never giving me a problem.
Check battery voltage & connections and they seemed fine. Do you think this was just a fluke or is there something else I need to check.

I did put in a brand new battery two weeks ago.

Thanks,

new battery install...

the term "check/checked", is a misnomer.... unless every connection, both the lugs on the battery, and every termination on a cable, or frame ground where a ring lug attaches is "removed, and abrasively cleaned (i.e. sand paper and shiny), and reconnected, the 'check' is a a visual misnomer.

you may have some harness issue, or other issue, that is related to something you may have 'added' to the bike also, but primarily it's the invisible resistive coating, that prevents perfect current flow.

when the bike starts, flip over to the battery charging screen on the LCD, and watch it as you ride a bit, and see if the charging and voltage stabalize within a few minutes, and settle at 14v while riding above 2k rpm. and also what it is at idle.
and external volt/ohm meter won't tell you charging status, just zero load voltage on the battery.

30 YEARS OF KAW.....Rich R. (the other one..)  COG 5977  JUSTAMEMBAHNOW
and if you are gonna call me names... it's MR. Analdweeb if you please...

Offline SandShark

  • Training Wheels
  • *
  • Posts: 54
  • "SandShark"
  • AREA: Southeast Area
  • COG#: 9045
  • Membership Level: Active
Re: Gauges Go Waco & Bike Dies
« Reply #3 on: October 20, 2018, 01:14:04 pm »
As I suspected bad ground.
Cleaned and checked all connections, sanded ground frame location.

😀Have gone on 4 rides and bike has road perfect😀
"It not the destination, but the ride"

COG #9045
2010 C-14 ABS, 2014 WR450F

Offline cuda

  • Crotch Rocket
  • ****
  • Posts: 1235
  • Ignorance Is Bliss.
  • AREA: Southeast Area
  • COG#: 11405
  • Membership Level: Active
Re: Gauges Go Waco & Bike Dies
« Reply #4 on: October 20, 2018, 01:35:10 pm »
No matter what your working on Grounds are the best place to start. :beerchug:
We have invented the world WE see .
It takes 20 years  to build a reputation and 5 minutes to lose it...   - Cog 11405

Offline Phil

  • Bicycle
  • *
  • Posts: 110
  • AREA: Northeast Area
  • COG#: forum
  • Membership Level: Forum Subscriber
Re: Gauges Go Waco & Bike Dies
« Reply #5 on: October 20, 2018, 05:00:22 pm »
No matter what your working on Grounds are the best place to start. :beerchug:

Well...maybe not a flat tire...    :))