Author Topic: The Long-Missed FI Error  (Read 757 times)

0 Members and 1 Guest are viewing this topic.

Offline Old Steve

  • Moped
  • **
  • Posts: 221
  • AREA: Southwest Area
  • COG#: 10537
  • Membership Level: Active
The Long-Missed FI Error
« on: November 11, 2017, 03:05:56 am »
It showed up this morning on the way to work, as I was going by some kind of brouhaha on the other side of the freeway involving three police cars with the lights going. The last FI I saw was about 25,000 miles ago.
I took it as a sign that I was doing something right.
Ride safe, y'all.

Offline khager01

  • Training Wheels
  • *
  • Posts: 76
  • AREA: South Central Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: The Long-Missed FI Error
« Reply #1 on: November 11, 2017, 03:24:44 am »
I have seen mine 2 or 3 times now, with 3500 miles.
2017 Concours 14
2012 V-Strom 650

Offline NinjaBreadMan

  • Mini Bike
  • **
  • Posts: 185
  • AREA: Northwest Area
  • COG#: 11944
  • Membership Level: Active
Re: The Long-Missed FI Error
« Reply #2 on: November 11, 2017, 04:12:31 am »
I have a theory that radio interference can cause the FI error.  Mine has shown up briefly twice, both when I was nearby a semi truck.  If yours came on when passing by the police cars, it also supports this idea.
2016 Gray C14
previous bikes 2006 C10, 1977 Z1000
Jet Ski ST-15F & STX-900
Lake Stevens, WA

Offline khager01

  • Training Wheels
  • *
  • Posts: 76
  • AREA: South Central Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: The Long-Missed FI Error
« Reply #3 on: November 12, 2017, 01:45:38 pm »
I have a theory that radio interference can cause the FI error.  Mine has shown up briefly twice, both when I was nearby a semi truck.  If yours came on when passing by the police cars, it also supports this idea.

I will try to keep that in mind next time it happens, but it is so infrequent I will probably forget by then! :))  OTOH maybe it is a built in warning that the POPO is nearby. ;D
2017 Concours 14
2012 V-Strom 650

Offline Steve in Sunny Fla

  • Industry Member
  • I Need a Life
  • *
  • Posts: 7365
  • AREA: Southeast Area
  • COG#: 6977
  • Membership Level: Active
Re: The Long-Missed FI Error
« Reply #4 on: November 12, 2017, 02:24:54 pm »
I have a theory that radio interference can cause the FI error.  Mine has shown up briefly twice, both when I was nearby a semi truck.  If yours came on when passing by the police cars, it also supports this idea.

I will try to keep that in mind next time it happens, but it is so infrequent I will probably forget by then! :))  OTOH maybe it is a built in warning that the POPO is nearby. ;D

BDF did a tech session addressing the various electronic issues at the 2014 Nationals, and as I recall he said other RF's could interfere, including garage door openers. It's good to know stuff like that, because when it comes to the electronics, everyone gets a little hinky when something isn't just right. Steve
C-14 ECU flashing for performance and rideability enhancement
C-10 Carb work , cams, & performance enhancements
 " Modifications for sport-tourers, BY a sport-tourer"
https://sites.google.com/site/shoodabenengineering/home

Offline DiverRay

  • Tricycle
  • Posts: 34
  • Ride Safe, Ride Fast
  • AREA: Southwest Area
  • COG#: 12498
  • Membership Level: Active
Re: The Long-Missed FI Error
« Reply #5 on: November 12, 2017, 08:13:50 pm »
Great....I am going to put a two way, 40 Watt radio on the bike! If it causes problems, it will tell me Kawi did a POOR JOB of shielding important electronics! I know they use this model for police bikes, so it should not have any problems. It may just be pointing out a ground loop, or poor ground someplace in the wire harness.
Ray Matteis
KE6NHG
2011 Concours
1978 XS1100 Yamaha (winter project)

Offline Just Cliff

  • Crotch Rocket
  • ****
  • Posts: 1162
  • 200,000 or Bust!
  • AREA: South Central Area
  • COG#: 9547
  • Membership Level: Event Host
Re: The Long-Missed FI Error
« Reply #6 on: November 12, 2017, 10:08:20 pm »
Maybe I don't pay enough attention to my dash or don't ride enough, but I have never seen the F1 code.

Cliff   :beerchug:

Offline ron203

  • Officer
  • Iron Butt
  • ****
  • Posts: 3800
  • AREA: Southeast Area
  • COG#: 9847
  • Membership Level: Area Director
Re: The Long-Missed FI Error
« Reply #7 on: November 13, 2017, 11:33:44 am »
Maybe I don't pay enough attention to my dash or don't ride enough, but I have never seen the F1 code.

Cliff   :beerchug:

 :rotflmao:
2014 C-14

Offline Baggerjohn

  • Training Wheels
  • *
  • Posts: 75
  • AREA: North Central Area
  • COG#: forum
  • Membership Level: Forum Subscriber
Re: The Long-Missed FI Error
« Reply #8 on: November 13, 2017, 04:18:29 pm »
I have a theory that radio interference can cause the FI error.  Mine has shown up briefly twice, both when I was nearby a semi truck.  If yours came on when passing by the police cars, it also supports this idea.
I've had it happen several times on my '12 but never on my '08 ABS.

Both have a J&M JMCB-2003 CB radio and a Yaesu FTM-10SR dual-band ham rig installed. Power distribution and filtering, antenna mounting and configuration and audio cabling are identical between the two - as are lighting accessories.

Every instance I've seen has occurred in the presence of a strong RF near-field. Many truckers run illegal power amplifiers or high-powered radios in their trucks...and Kawasaki may not have taken this into account when they did RF screen-room ingress testing of the bike's CAN-Bus setup.

Offline Not So Wild Turkey

  • Road Bike
  • ***
  • Posts: 337
  • AREA: South Central Area
  • COG#: 10559
  • Membership Level: Active
Re: The Long-Missed FI Error
« Reply #9 on: November 14, 2017, 09:36:58 am »
Yep Cliff you def def definitely don't ride enough.  Prolly cause the roads are no fun in your area.  What? Woop maybe that was a brain fart.  Or more likely the ever possible flashback.  Just proves Ted is right.  I've got no clue what I'm talking about.
2012 Concours Arabian Red & 80 Suzuki GS1100E
2003 VTX1800R Black / 1979 Suzuki GS1000E / 1969 Norton Commando
Yamaha DT3 250 / Kawasaki 100 G4TR

Offline gpd323

  • Street Cruiser
  • ****
  • Posts: 932
  • AREA: Northwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: The Long-Missed FI Error
« Reply #10 on: November 14, 2017, 02:46:02 pm »
Mine does it from time to time, just pops up with a quick red-light dash warning and F1 error shows then disappears. I don't worry about it.  :beerchug:

Greg Downing
Beautiful Downtown Spanaway
Washington State

Ride while you can.

Offline Harry Martin

  • ☺ Cartoonist ☺
  • Crotch Rocket
  • ****
  • Posts: 1006
  • Fear is not boring
    • Harry Martin Cartoons
  • AREA: Northwest Area
  • COG#: 4090
  • Membership Level: Active
Re: The Long-Missed FI Error
« Reply #11 on: November 15, 2017, 11:02:24 am »
Some how, I don't buy that explaination. I seen it twice now in the wyoming wastelands. No where near anything sporting RF or spinning electrons.

I suspect a software glitch or worse...foul play by that dasterly slow riding low life Ted. He's good at mind control and worse...just saying.
Harry in Wild and Windy Casper, WY - 1986 Vintage "Silverdammit" - 2015 "Greendammit"

Offline Baggerjohn

  • Training Wheels
  • *
  • Posts: 75
  • AREA: North Central Area
  • COG#: forum
  • Membership Level: Forum Subscriber
Re: The Long-Missed FI Error
« Reply #12 on: November 15, 2017, 07:35:03 pm »
Some how, I don't buy that explaination. I seen it twice now in the wyoming wastelands. No where near anything sporting RF or spinning electrons.
Cell towers in the vicinity?

Microwave links?

OTH radars?

RF energy can propagate a good distance across open terrain - out of sight of the transmitting antenna - and depending upon frequency, still have adequete power density at the receiving end to induce weirdness in susceptible electronics.

Offline Harry Martin

  • ☺ Cartoonist ☺
  • Crotch Rocket
  • ****
  • Posts: 1006
  • Fear is not boring
    • Harry Martin Cartoons
  • AREA: Northwest Area
  • COG#: 4090
  • Membership Level: Active
Re: The Long-Missed FI Error
« Reply #13 on: November 15, 2017, 08:54:15 pm »
I read in another forum that two C14s on the same ride experienced the "FI" at the same time.
Not sure if it was the exact same time or just randomly on the same ride.

However, if at the same time, then I would conclude that it was caused by some sort of interference. Maybe Ted has twice the brain power and mentally caused this to happen. I believe Ted has zero brain power, so 2 x 0 brain power is still zero, so who knows.

I reread the owners manual looking for clues and it's not much help. The only clue if any is that it is related to the Fuel Injection fault message.

Reading up on fuel injectors I find that "The amount of fuel supplied to the engine is determined by the amount of time the fuel injector stays open. This is called the pulse width, and it is controlled by the ECU."

From my engineering electronic design days, I recall that electro-magnets are energy storage devices. They don't like changes in their stored magnetic fields. So maybe, Big K did not put shunting diodes across them injector electro-magnets. Maybe they did and are not exactly right. When their pulse power is switched off, the field collapses resulting in an energy spike in all frequencies. The diode is supposed to prevent that by providing a path to short out the EMF. Now, suppose at just the right moment, some stray RF gets in there and adds to the collapsing field, maybe stretching it out a tad and the ECU detects it and throws a fault. But, as what usually happens, we get pass the RF and all returns to normal rather quickly.

Owners manual says "FI" is for a hard fuel injector fault and should show some hard fault code associated with it, but none appears. So maybe, just maybe, it's a soft fault that resets itself after some rather quick on the fly diagnostic. I can see it happening. Our F18 fighter jets have fly by wire systems that do real time fault analysis while flying. They detect errors on the fly and may or may not produce hard or soft faults. I don't know if this is the case or not for our C14s, but I would like to think so. It would explain the "FI" going away after a soft fault being cleared.

Who knows. Big K doesn't tell us everything. It would be nice to talk to the software engineers who cobbled up the system.

Then again...there is Ted... :(
Harry in Wild and Windy Casper, WY - 1986 Vintage "Silverdammit" - 2015 "Greendammit"