Author Topic: UPDATE: Rear brake/ ABS issue?  (Read 3171 times)

0 Members and 1 Guest are viewing this topic.

Offline Afm252

  • Tricycle
  • Posts: 19
  • AREA: South Central Area
  • COG#: forum
  • Membership Level: Forum Subscriber
UPDATE: Rear brake/ ABS issue?
« on: March 06, 2016, 05:43:58 pm »
Howdy all. I have been a member a while, but rarely post. Big issue on my '09 ABS that I need an assist before taking to the dealer.
After 36k uneventful miles and having accomplished the brake recall, my rear brake lever has locked up. Took it to a trusted non-dealer shop and it seems not to be a straightforward mechanical issue. Code pops up indicating either wiring harness or ABS pump issue. Either in this case may be a costly proposition.

Thoughts?
« Last Edit: April 05, 2016, 03:36:57 pm by Afm252 »
2014 C7 Z51 "Therapy Vette"
2009 C14ABS Black
Gone 2007 CBR600RR
Gone 1998 CBR600F3

Offline Steve in Sunny Fla

  • Industry Member
  • I Need a Life
  • *
  • Posts: 7875
  • AREA: Southeast Area
  • COG#: 6977
  • Membership Level: Active
Re: Rear brake/ ABS issue?
« Reply #1 on: March 06, 2016, 06:35:32 pm »
happened to my 09 also. I ended up buying a pump from ebay, fixed upon installation  :motonoises: Steve
C-14 ECU flashing for performance and rideability enhancement
C-10 Carb work , cams, & performance enhancements
 " Modifications for sport-tourers, BY a sport-tourer"
https://sites.google.com/site/shoodabenengineering/home

Offline gPink

  • Iron Butt
  • *****
  • Posts: 3226
  • MMVIII C XIV
  • AREA: North Central Area
  • COG#: Forum
  • Membership Level: Forum Subscriber

Offline Freddy

  • Road Bike
  • ***
  • Posts: 446
  • AREA: Southwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Rear brake/ ABS issue?
« Reply #3 on: March 06, 2016, 10:48:54 pm »
This is the first report of a code 'popping up' and a good thing it is too!

Is the code 'popping up' on the dash display OR in the separate process when the ABS unit is put into diagnostic mode by the mechanic?  I assume the latter.
The best substitute for brains is ..............what?

Offline Afm252

  • Tricycle
  • Posts: 19
  • AREA: South Central Area
  • COG#: forum
  • Membership Level: Forum Subscriber
Re: Rear brake/ ABS issue?
« Reply #4 on: March 07, 2016, 01:07:14 am »
Freddy, Mechanic used a diagnostic computer to diagnose. Came up with code 52 in the ABS system.

Steve, looks like if I have to pay for a pump, the flash is being pushed back again...bummer
2014 C7 Z51 "Therapy Vette"
2009 C14ABS Black
Gone 2007 CBR600RR
Gone 1998 CBR600F3

Offline Freddy

  • Road Bike
  • ***
  • Posts: 446
  • AREA: Southwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Rear brake/ ABS issue?
« Reply #5 on: March 07, 2016, 04:59:56 am »
Freddy, Mechanic used a diagnostic computer to diagnose. Came up with code 52 in the ABS system.



I assume the bike's own diagnostic computer, not an external one.  Chart below from the series 1 service manual.

Kawasaki may well replace the ABS unit free of charge, as in posts linked to the link above.  It seems they may be keen to get their hands on faulty units.    Please   report the failure to  NHTSA in the interests of other riders and road users.






Note that code 13 and/or 14, the failure a growing number have experienced, is the one which SHOULD cause the ABS light to stay on, BUT DOES NOT.  Imagine what could happen if the failure was in the front circuit!
« Last Edit: March 07, 2016, 09:01:55 am by Freddy »
The best substitute for brains is ..............what?

Offline Steve in Sunny Fla

  • Industry Member
  • I Need a Life
  • *
  • Posts: 7875
  • AREA: Southeast Area
  • COG#: 6977
  • Membership Level: Active
Re: Rear brake/ ABS issue?
« Reply #6 on: March 07, 2016, 01:16:48 pm »
Mine didn't throw the light on, just locked the rear brake. Definitely the abs unit. Steve
C-14 ECU flashing for performance and rideability enhancement
C-10 Carb work , cams, & performance enhancements
 " Modifications for sport-tourers, BY a sport-tourer"
https://sites.google.com/site/shoodabenengineering/home

Offline MAN OF BLUES

  • I Need a Life
  • ******
  • Posts: 9768
  • AREA: North Central Area
  • COG#: 5977
  • Membership Level: Active
Re: Rear brake/ ABS issue?
« Reply #7 on: March 07, 2016, 05:10:22 pm »
after seeing that code, id suggest checking all the connectors on the cicuits associated with ABS.
SISF can attest that in the past, sometimes the pins in the connector housing get pushed back out of position, and failnto maintain good contact, he found this once on the throttle return sensor I believe. id unplug, inspect both connectors, push all the wires firmly back into the fonnector while plugging it in, and see if it still trips the code. it would be a shame to purchase a unit only to find the connector had a wire compromised, just tossing this out there for thought.

30 YEARS OF KAW.....Rich R. (the other one..)  COG 5977  JUSTAMEMBAHNOW
and if you are gonna call me names... it's MR. Analdweeb if you please...

Offline Afm252

  • Tricycle
  • Posts: 19
  • AREA: South Central Area
  • COG#: forum
  • Membership Level: Forum Subscriber
Re: Rear brake/ ABS issue?
« Reply #8 on: March 13, 2016, 03:00:09 pm »
Thanks all. I will consult with the Kawi dealer.

Do any of you know if the ABS pump from the 2010 and higher will work with the 2009? They are different part numbers.
2014 C7 Z51 "Therapy Vette"
2009 C14ABS Black
Gone 2007 CBR600RR
Gone 1998 CBR600F3

Offline jwh20

  • Crotch Rocket
  • ****
  • Posts: 1985
  • AREA: North Central Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Rear brake/ ABS issue?
« Reply #9 on: March 13, 2016, 07:01:54 pm »
Thanks all. I will consult with the Kawi dealer.

Do any of you know if the ABS pump from the 2010 and higher will work with the 2009? They are different part numbers.

No definitive answer but there is another thread currently going on that had a couple members indicate that the 2010+ ABS pump has a different electrical interface than the 08-09 model.  That's quite possibly the case.  The 2010 and later units are more common but I'm sure a wreck from an 08 or 09 will show up sooner or later.
2012 Concours 14 Arabian Red
"Debbie Downer" according to some...

Offline MAN OF BLUES

  • I Need a Life
  • ******
  • Posts: 9768
  • AREA: North Central Area
  • COG#: 5977
  • Membership Level: Active
Re: Rear brake/ ABS issue?
« Reply #10 on: March 13, 2016, 07:27:10 pm »
Thanks all. I will consult with the Kawi dealer.

Do any of you know if the ABS pump from the 2010 and higher will work with the 2009? They are different part numbers.

No definitive answer but there is another thread currently going on that had a couple members indicate that the 2010+ ABS pump has a different electrical interface than the 08-09 model.  That's quite possibly the case.  The 2010 and later units are more common but I'm sure a wreck from an 08 or 09 will show up sooner or later.

they do differ,
wheel rotor sensor differs also, that's where the signal comes from in pulses being sensed...
08 front is. 21007-0068   ROTOR,SENSOR,FR
16082-0023   PUMP-ASSY-OIL,WET TYPE

21007-0069   ROTOR,SENSOR,RR
21176-0076   SENSOR,SPEED,RR


2010 is
21007-0140   ROTOR,SENSOR,FR
16082-0041   PUMP-ASSY-OIL,WET TYPE
21007-0141   ROTOR,SENSOR,RR
21176-0131   SENSOR,SPEED,RR

hope this helps, maybe a sticky is in order to preserve this?
« Last Edit: March 13, 2016, 07:37:28 pm by MAN OF BLUES »

30 YEARS OF KAW.....Rich R. (the other one..)  COG 5977  JUSTAMEMBAHNOW
and if you are gonna call me names... it's MR. Analdweeb if you please...

Offline Afm252

  • Tricycle
  • Posts: 19
  • AREA: South Central Area
  • COG#: forum
  • Membership Level: Forum Subscriber
Re: Rear brake/ ABS issue?
« Reply #11 on: March 14, 2016, 11:35:54 pm »
Makes a lot of sense. Going to have to see if a part pops up on eBay or find a salvage. New part is pricey! Really kills the farkle list...Steve, may have to push you back some more...dang it!
2014 C7 Z51 "Therapy Vette"
2009 C14ABS Black
Gone 2007 CBR600RR
Gone 1998 CBR600F3

Offline Freddy

  • Road Bike
  • ***
  • Posts: 446
  • AREA: Southwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: Rear brake/ ABS issue?
« Reply #12 on: March 16, 2016, 12:00:29 pm »
Kawasaki may well replace the ABS unit free of charge, as in posts linked to the link above.  It seems they may be keen to get their hands on faulty units.    Please   report the failure to  NHTSA in the interests of other riders and road users.



Why not ask Kaw for a new one?  It's a safety issue they are aware of and have supplied some to owners free of charge.
The best substitute for brains is ..............what?

Offline Afm252

  • Tricycle
  • Posts: 19
  • AREA: South Central Area
  • COG#: forum
  • Membership Level: Forum Subscriber
UPDATE Re: Rear brake/ ABS issue?
« Reply #13 on: April 05, 2016, 03:36:18 pm »
Great news, Mama Kawi agreed to cover the ABS pump and labor. They were top notch in dealing win this issue. Part will be going back to Kawasaki for analysis.
2014 C7 Z51 "Therapy Vette"
2009 C14ABS Black
Gone 2007 CBR600RR
Gone 1998 CBR600F3

Offline Big Ed RI

  • Bicycle
  • *
  • Posts: 51
  • AREA: Southeast Area
  • COG#: 12428
  • Membership Level: Forum Subscriber
Re: UPDATE Re: Rear brake/ ABS issue?
« Reply #14 on: April 06, 2016, 09:31:46 am »
Great news, Mama Kawi agreed to cover the ABS pump and labor. They were top notch in dealing win this issue. Part will be going back to Kawasaki for analysis.

good to hear!  Mine had been working fine since the fix, and Kawi did mine gratis as well.

Offline Freddy

  • Road Bike
  • ***
  • Posts: 446
  • AREA: Southwest Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: UPDATE: Rear brake/ ABS issue?
« Reply #15 on: April 06, 2016, 10:34:56 am »
Yu've gotta like that.   :)
The best substitute for brains is ..............what?