Author Topic: "Inverse" Petcock Failure  (Read 3117 times)

0 Members and 1 Guest are viewing this topic.

Offline LeeW

  • Tricycle
  • Posts: 11
  • AREA: Northeast Area
  • COG#: 10398
  • Membership Level: Active
"Inverse" Petcock Failure
« on: June 05, 2014, 12:12:53 pm »
I was on the New York slab, heading to Americade on my 87 C-10, about 50 miles into the trip. Not pushing, 4K RPM 70ish mph. A ratty minivan passed me like I was standing still. I thought to myself...he shouldn't push that rust bucket so hard... I can smell the gasoline from way back here....Then looked down, it looked like one of those WW2 movies where the plane gets hit and the fuel is spewing. I pulled over, shut down.
I could see where the fuel was coming from, but nothing seemed to be leaking. I wiped everything down and fired her back up. With that, fuel spewed from the petcock. Shut her down....no leaks. Tried to tighten the screws that hold the petcock assembly together, but they were not loose.
It appeared that when vacuum pulled in the line, the petcock spewed, no vacuum, no leaks.

Well, I was done... called the wife, she hit U-Haul for a trailer and came up to rescue me (I owe her big time!).
A really cool New York State Trooper stopped to see if I was OK, as did one of hundreds of bikes that passed by on the way up to the rally.

The only cool thing about sitting on the side of the slab is that I was able to order the replacement petcock from Murph's before the gas dried!

Drained the tank into some gas cans...trailered home...burned my bald head sitting in the sun...but it could have been much worse.

The moral of the story...don't neglect your petcocks.

Stay safe out there....Lee
All the art of living lies in a fine mingling of letting go and holding on. - Havelock Ellis

87 C10

Offline Rev Ryder

  • Officer
  • I Need a Life
  • ****
  • Posts: 8784
  • We came. We saw. We Concours-ed.
    • Presbychuck
  • AREA: South Central Area
  • COG#: 7235
  • Membership Level: Executive Director
Re: "Inverse" Petcock Failure
« Reply #1 on: June 05, 2014, 01:17:46 pm »
Sorry for the bad day Lee.  If this kind of thing ever happens to you again, pull the vacuum line and plug it with a stick or bolt or pebble, put the petcock on PRI and ride on.  You can then turn it off by switching to ON when you stop.  That should get you going until you can replace it.  I know it's too late to help this time, but maybe someone else will benefit.  Hope you get her back on the road soon and glad you didn't go down in flames like those planes in the movies sometimes do.  :great:
Fortis non Ferox
 Shafties Can't Wheelie

Offline Jim

  • Street Cruiser
  • ****
  • Posts: 661
  • Jim
  • AREA: South Central Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Re: "Inverse" Petcock Failure
« Reply #2 on: June 05, 2014, 01:56:33 pm »
If it was leaking from the back of the petcock (small weep hole), it's probably the vacuum diaphragm.  When it went out on mine, switching to PRIME was no help since the fuel flow by-passes the vacuum operated stopper but still flows into the cavity with the failed diaphragm then out to the carbs.
Has anyone ever used gas tank leak putty over this weep hole for a temporary repair?
« Last Edit: June 05, 2014, 02:00:06 pm by Jim »

Offline DamDan

  • Road Bike
  • ***
  • Posts: 333
  • AREA: Northwest Area
  • COG#: 5420
  • Membership Level: Active
Re: "Inverse" Petcock Failure
« Reply #3 on: June 05, 2014, 07:35:09 pm »
Petcock blues! With well over 250K Connie miles under my belt, I've had three things fail two or more times. Speedo cable (multiple) shift linkage ball joint (two) and the famous petcock (two). Only time I was stranded by any of this was the first time the shift linkage broke. A fellow "rider" saved the day that time and I carry the repaired unit in my tool roll and have used it once again. As far as petcocks go, both times my bike and I were (luckily) at home when we experienced hydro lock due to the petcock failure along with old needle and seats. Luckily, we experianced no major damage either time. Failures were probably at about 100K and 130K. Bike now has 150K.  :great:

Offline VTconnie

  • Crotch Rocket
  • ****
  • Posts: 1613
  • AREA: Northeast Area
  • COG#: 11081
  • Membership Level: Active
Re: "Inverse" Petcock Failure
« Reply #4 on: June 05, 2014, 09:42:24 pm »
I bit the bullet and got an OEM from Murph's when doing my jet kit last week. How adult of me  :)
<--2003 Concours C-10 "Conifer", -AKA- The Cruise Missile
1980 CB900C DOHC "Old Iron" -AKA- The Hill Climber                

Online Mettler1

  • Iron Butt
  • *****
  • Posts: 3343
  • You want answers? We got answers!!
  • AREA: North Central Area
  • COG#: 1431
  • Membership Level: Active
Re: "Inverse" Petcock Failure
« Reply #5 on: June 05, 2014, 10:00:44 pm »

   Replaced my oem petcock 5 yrs ago with Murphs' oem petcock. Still good. Ist one lasted 15 yrs and figured it was time for a new one.
'94 Concours 115,000 miles-- 7th gear,2MM,KB fork brace,Over flowtubes,Stick coils,Tcro shifter,GPS,SiSF'sTorque cams,SPOOKFAK,block off plates, SS brake & clutch lines,KB risers, FENDA EXTENDA, emulators, SiSF carb Spa, Delkevic exhaust, Murphs' knee savers +grips, etc

Offline Uncle Rob

  • Road Bike
  • ***
  • Posts: 344
  • "Knock it off with those negative waves!"
  • AREA: Southeast Area
  • COG#: 11810
  • Membership Level: Active
Re: "Inverse" Petcock Failure
« Reply #6 on: June 07, 2014, 10:52:26 am »
I had a petcock leak that only happened when it was running.  Gas was coming out of the weep hole.  Rebuilt the petcock and it is fine now.  I didn't see any obvious failure of the old diaphragm but i did sand both surfaces with 220 wet/dry on a flat surface to make sure that they were flat.  Murph has a note on his website about not over tightening the screws on the petcock.  I am assuming that this can warp the metal surfaces.
2003 C10
1999 Buell X1
Others in pieces

Rob Thomson

Offline Rev Ryder

  • Officer
  • I Need a Life
  • ****
  • Posts: 8784
  • We came. We saw. We Concours-ed.
    • Presbychuck
  • AREA: South Central Area
  • COG#: 7235
  • Membership Level: Executive Director
Re: "Inverse" Petcock Failure
« Reply #7 on: June 07, 2014, 01:19:01 pm »
Yes, it's pretty rare to see one actually flat.
Fortis non Ferox
 Shafties Can't Wheelie

Offline jetta90

  • Tricycle
  • Posts: 28
  • AREA: Northwest Area
  • COG#: forum
  • Membership Level: Forum Subscriber
Re: "Inverse" Petcock Failure
« Reply #8 on: June 08, 2014, 08:30:17 pm »
Coincidentally......I just picked up a new petcock from the local Kawasaki dealer yesterday.  The 02 Concours I bought a year and a half ago with 66,000 kms (just under 40,000 miles) will have a new petcock shortly.  Not that the old one has any issues at this point. ;)

Offline DamDan

  • Road Bike
  • ***
  • Posts: 333
  • AREA: Northwest Area
  • COG#: 5420
  • Membership Level: Active
Re: "Inverse" Petcock Failure
« Reply #9 on: June 09, 2014, 07:40:52 pm »
Better safe than sorry at this point!

Offline LeeW

  • Tricycle
  • Posts: 11
  • AREA: Northeast Area
  • COG#: 10398
  • Membership Level: Active
Re: "Inverse" Petcock Failure - Epilog
« Reply #10 on: June 15, 2014, 02:19:36 pm »
I installed Murph's OEM replacement... no surprises... up and running again.

What was a interesting is I disassembled the old petcock expecting to find the reason why I went from"bone dry" to looking like I got shot in the tank. Nothing.... no torn diaphragm, no broken O ring...

So how to say this with out opening myself to a barrage of innuendo.... Gentlemen, don't neglect your petcock!

Be safe out there!
Lee
All the art of living lies in a fine mingling of letting go and holding on. - Havelock Ellis

87 C10

Offline WillyP

  • I Need a Life
  • ******
  • Posts: 6122
  • Live Free Or Die
    • Suncook Carpentry
  • AREA: Northeast Area
  • COG#: 8799
  • Membership Level: Active
Re: "Inverse" Petcock Failure
« Reply #11 on: June 15, 2014, 03:10:21 pm »
As Brian would say... easy, boys!
Smart people look like crazy people to stupid people.
pics