Author Topic: Bad clutch...  (Read 207 times)

0 Members and 1 Guest are viewing this topic.

Offline Danny sparks

  • Tricycle
  • Posts: 33
  • AREA: Northeast Area
  • COG#: Forum
  • Membership Level: Forum Subscriber
Bad clutch...
« on: August 27, 2017, 03:47:33 pm »
Had the bike out today...and give it a dam good   Thrashing ....with the new c14 rear shock...what a difference..speeds up 100mph..with no problem.... bike was going great..until felt a  feeling in the clutch lever ..like a bump....have I snapped my leaf spring....parked the bike up .jumped back on .no bump in lever...is this something I should give  immediate attention to.or just keep on riding...cheers chaps

Offline DC Concours

  • Crotch Rocket
  • ****
  • Posts: 1837
  • 2001 Concours, ~17K miles
  • AREA: Northeast Area
  • COG#: forum
  • Membership Level: Forum Subscriber
Re: Bad clutch...
« Reply #1 on: August 27, 2017, 09:29:40 pm »
model year and how many miles? that spring issue was taken care of in the newer models

but I guess if you keep on "dam good thrashing" it you might need a new transmission along with the clutch soon!


Had the bike out today...and give it a dam good   Thrashing ....with the new c14 rear shock...what a difference..speeds up 100mph..with no problem.... bike was going great..until felt a  feeling in the clutch lever ..like a bump....have I snapped my leaf spring....parked the bike up .jumped back on .no bump in lever...is this something I should give  immediate attention to.or just keep on riding...cheers chaps

Offline MAN OF BLUES

  • I Need a Life
  • ******
  • Posts: 6724
  • AREA: North Central Area
  • COG#: 5977
  • Membership Level: Active
Re: Bad clutch...
« Reply #2 on: August 27, 2017, 10:13:47 pm »

30 YEARS OF KAW.....Rich R. (the other one..)  COG 5977  JUSTAMEMBAHNOW