Author Topic: 1967 suzuki b100p. Had one?  (Read 734 times)

0 Members and 1 Guest are viewing this topic.

Offline Brent

  • Training Wheels
  • *
  • Posts: 91
  • AREA: North Central Area
  • COG#: 10203
  • Membership Level: Expired - Expired Term
1967 suzuki b100p. Had one?
« on: September 28, 2013, 01:16:29 am »
I know it's a long shot but I have a girl friend that bought one of these last winter to scoot around town. Tonight she was on her way home and  it wouldn't come out of 4th gear. I can't find much info on these on the web. It won't shift out of 4th running or not. Any idea's or experience with this vintage bike?

Offline Jerry

  • Mini Bike
  • **
  • Posts: 193
  • AREA: Northwest Area
  • COG#: 11147
  • Membership Level: Active
Re: 1967 suzuki b100p. Had one?
« Reply #1 on: September 28, 2013, 11:35:21 pm »
I've got a 1979 100 and I would guess its the shifting fork, or the foot shifting lever slipping on the spline. I've never has any issues with this bike. good luck
On hand, 1966 triumph tiger,1969 triumph trophy,1975 yamaha dt 400, 1977 yamaha IT 175, 1979 suzuki TS 100, 2009 C-14, 2010  H.D. XR1200

Offline Tim

  • Mini Bike
  • **
  • Posts: 177
  • AREA: North Central Area
  • COG#: 11237
  • Membership Level: Active
Re: 1967 suzuki b100p. Had one?
« Reply #2 on: September 29, 2013, 12:47:28 pm »
friend of mine just went thru this on his ktm 300exc. it stuck in first gear. turned out to be a piece of debris from an earlier kickstart mechanism failure got wedged tween shifter mechanism inside inner clutch cover. nothing wrong with trans itself.
There will only be two things left moving after WW3.
Cockroaches & KLRs.